Security Notices

Buffalo EU is aware of the importance of security and the vulnerabilities that come up and investigates its product line regularly. We care for our customers and release new updates where necessary. Buffalo recommends downloading the latest versions of our firmware.

Check the list of identified vulnerabilities and products affected:

Date

Description of vulnerability and updates

Affected Products

December 12, 2017

Initiates file downloadINTEL-SA-00086

No products affected

December 12, 2017

Initiates file downloadSamba-VulnerabilityCVE-2017-14746 , CVE-2017-15275)

TeraStation™, LinkStation™, AirStation™

November 2017

Initiates file downloadWPA2-Vulnerability

Wireless Routers, USB adapters

June 2, 2017

Initiates file downloadSamba vulnerability CVE-2017-7494

TeraStation™, LinkStation™, AirStation™